simple tagsめ!wordpress2.9のアップデートでまたまた動かない

イテル on 02 5, 2010

またまたsimple tagsめ!wordpress2.9のアップデートでまたまた動かない

wp2.9にアップデートした際にも発生したのですが、
また懲りずに不具合が発生したのでメモ。

前回はwpを2.9にアップデートしたことにより、プログラム中のバージョンチェックで
2.9が認識できないという不具合でした。
この場合は、2.9のチェックを入れてあげればokでした。

どちらかというと、「wp」をバージョンアップしたことによって引き起こされた不具合なので
誰が悪いということもなかったのですが、今回は「simple tags」のアップデートを
すると動作しなくなるという不具合。。。

まともやgoogle先生に聞いてみるとすぐに発見。
※いつものことながら、問題を1週間ほど寝かせた後ですがw

参考:Simple Tagsのエラー解決策(Kazuizmさん)
※本当に助かりました!

「inc/base.php」の46行目を修正すればokとのことです。

元のコード

	/**
	 * Add initial ST options in DB
	 *
	 */
	function installSimpleTags() {
		$options_from_table = get_option( STAGS_OPTIONS_NAME );
		if ( $options_from_table == false ) {
			$this->resetToDefaultOptions();
		}
	}

修正したコード

	/**
	 * Add initial ST options in DB
	 *
	 */
	function installSimpleTags() {
		$options_from_table = get_option( STAGS_OPTIONS_NAME );
		if ( $options_from_table == false ) {
			$this->options = $this->resetToDefaultOptions();
		}
	}

※「$this->options =」が抜けているようです。。。凡ミスですねw

ステキなプラグインだけに、リリース前チェックはして欲しいところですw

Leave a Reply